What kind of system should I have?

PARiConnect works with a variety
of devices and browsers

PARiConnect requires a Windows®-based or Mac® desktop or laptop computer with an Internet connection and the latest version of one of the following Web browsers: Chrome™, Safari®, or Firefox®. PARiConnect also runs on Internet Explorer® versions 9, 10, and 11. In addition, PARiConnect will run on any version of the full size Apple® iPad® with the latest version of Safari.

Try PARiConnect